Cpanel change PHP handler error

There appears to be a bug somewhere  in the cpanel EA4 upgrade process. When changing the php handler after the conversion, you may see an error like this: API failure: (XID ntgxgd) Provide the “type” parameter for the “Cpanel::WebServer::Supported::apache::make_handler” function. I found that this error was caused by the yum-plugin-universal-hooks package, not being installed properly at the time of the conversion. To correct this and be able to change php handlers in Easy apache 4, you will need to do the following: yum reinstall yum-plugin-universal-hooks /scripts/migrate_ea3_to_ea4 –reinstall –run These commands will reinstall the  yum-plugin-universal-hooks and then recompile EA4 to include the correct hooks.   If you are using cloud linux,… Read More

Continue Reading